Minimum system requirements for Connect

To use Connect, your computer or mobile device should meet the following minimum system requirements for web browsers and mobile device operating systems.

Web browsers

When using Connect, we recommend you use the latest supported browser version and always apply all available security updates.

See a list of supported browsers to ensure you have the most current version available.

Web browsers must allow cookies. If your browser is not configured to allow cookies, you will see an alert that cookies must be enabled to log in.

Mobile devices

We recommend you use the 'Appian' app for iOS and Android instead of a mobile internet browser if accessing Connect from a mobile device.

Always upgrade to the latest available version of the app for the best experience and latest features.

Supported mobile operating systems for app

Mobile platform Mobile operating system version Appian for Mobile Devices version
iOS iOS 8 or later 2.8.4 or later
Android Android 4.0 or later 2.8.3 or later

Technical support

Support is available Monday–Friday 8.30am–4.30pm (AEST) (except public holidays).

Also consider...